composer dump-autoload 를 실행하면 다음의 경고 메시지가 출력됨

 

- 경고 메시지
Deprecation Notice: Class php does not comply with psr-4 autoloading standard. It will not autoload anymore in Composer v2.0. in phar://C:/composer/composer.phar/src/Composer/Autoload/ClassMapGenerator.php:185

- 원인
클래스 이름과 파일이름이 다른 경우 출력됨

- 해결방법
클래스 이름과 동일하게 파일이름을 변경한다.

//----------------------------

// 참고

 

* composer 최신 버전으로 업그레이드

composer self-update

 

 

* 설치된 패키지 보기

composer show

 

Posted by 코덴스

댓글을 달아 주세요