[vc6] VC6에서 최신(XP) DDK 사용

 

* 소개

DDK Version

현재(2007.05.31) DDK의 최신 버전은 6000(Windows Driver Kit (WDK)) Vista를 지원한다.

2600.1106 - xp sp1(기준, 테스트로 쓰임)

3790.1830 - win 2003 sp1

 

* 현상

ddk(wxp sp1)을 이용해서 vc6으로 컴파일 하려고 하면 컴파일러 버전이 구려서 지원하지 않는다고 나온다

w2k ddk로 경로 설정을 하면 되지만 PsRemoveCreateThreadNotifyRoutine()과 같은 함수는 wxp에서 지원한다.

그래서 경로를 wxp로 설정하고도 컴파일이 되도록 해보자

 

* 해결책

- include path

$DDK$\inc\wxp

$DDK$\inc\ddk\wxp

 

- library path

$DDK$\lib\wxp\i386

 

- 요기가 중요

$DDK$\inc\ddk\wxp\ntddk.h 수정

#if _MSC_VER < 1300

-> #if _MSC_VER < 1200 //vc6 == 1200

VC6의 내부 컴파일러 버전은 1200이다. ntddk.h에서 이걸 검사해서 막고 있으므로 이곳을 수정한다.

이렇게 컴파일해서 쓰고 있지만 아직 에러는 발생하지 않는 듯하다.


Posted by 코덴스

댓글을 달아 주세요